AGDInteractive - Sierra Adventure Game Remakes Forum
http://www.agdinteractive.com/forum/

Mark all posts read
http://www.agdinteractive.com/forum/viewtopic.php?f=18&t=14398
Page 1 of 1

Author:  GuJiaXian [ Tue Aug 11, 2009 3:48 pm ]
Post subject:  Mark all posts read

Dunno if it matters, but this button no longer works for me. I mean, it still *says* it's marked them all as read, but as soon as the forum list refreshes, nothing actually has been marked as read. I've tried logging out, deleting cookies, etc.

Author:  MusicallyInspired [ Wed Aug 12, 2009 1:17 am ]
Post subject:  Re: Mark all posts read

Same with me. Been like that for months now. I sent a PM to AGD2, Navynuke and Erpy about it but got no response. It only fails on the board index, though. And doesn't actually return a message at all after you do it. Just gives a link back to the index. Mark Threads As Read works within each forum separately, though, but that gets annoying.

Author:  GuJiaXian [ Wed Aug 12, 2009 2:02 am ]
Post subject:  Re: Mark all posts read

Very true.

On another note, I realized that I've been registered here for over six years and still have less than 100 posts.

Author:  Brainiac [ Wed Aug 12, 2009 12:08 pm ]
Post subject:  Re: Mark all posts read

GuJiaXian wrote:
On another note, I realized that I've been registered here for over six years and still have less than 100 posts.


So post one more. C'mon, you can do it!

Author:  GuJiaXian [ Thu Aug 13, 2009 4:33 am ]
Post subject:  Re: Mark all posts read

Nope, won't do it.


...crap!

Author:  MusicallyInspired [ Thu Aug 13, 2009 3:03 pm ]
Post subject:  Re: Mark all posts read

He totally set you up for that lolz.

Author:  Angelus3K [ Fri Aug 14, 2009 7:48 am ]
Post subject:  Re: Mark all posts read

My Mark All Read has always worked and still does. Might be something to do with your cookies.

Author:  MusicallyInspired [ Fri Aug 14, 2009 2:57 pm ]
Post subject:  Re: Mark all posts read

On the board index?

EDIT: Nope. I just tried it on my Wii and it doesn't work there either.

Author:  Angelus3K [ Sat Aug 15, 2009 9:06 am ]
Post subject:  Re: Mark all posts read

MusicallyInspired wrote:
On the board index?

EDIT: Nope. I just tried it on my Wii and it doesn't work there either.


Yea your right, doesn't work from board index but does work inside each forum.

Author:  MusicallyInspired [ Sat Aug 15, 2009 1:52 pm ]
Post subject:  Re: Mark all posts read

That's what I said earlier. :p

Author:  GuJiaXian [ Thu Aug 27, 2009 12:04 pm ]
Post subject:  Re: Mark all posts read

I guess no one's interested in fixing the board functionality. Ah, well.

Author:  Broomie [ Thu Aug 27, 2009 1:57 pm ]
Post subject:  Re: Mark all posts read

This is a common problem with many custom themes being converted over to phpBB 3.0. The Mark All Posts link simply refreshes the index page and does nothing. An admin needs to access index.php and replace this:

Code:
   'U_MARK_FORUMS'      => ($user->data['is_registered'] || $config['load_anon_lastread']) ? append_sid("{$phpbb_root_path}index.$phpEx", 'hash=' . generate_link_hash('global') . '&f=' . $root_data['forum_id'] . '&mark=forums') : '',


with this

Code:
'U_MARK_FORUMS'      => ($user->data['is_registered'] || $config['load_anon_lastread']) ? append_sid("{$phpbb_root_path}", 'hash=' . generate_link_hash('global') . '&mark=forums') : '',


That should work although I haven't tested it myself as I use SMF but it seemed to work for a number of people who had similar problems. Although another way is to update the forum firmware to the latest version.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/