It is currently Tue Oct 24, 2017 5:37 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Submenu Issue - VMWare Fusion / OS X
PostPosted: Tue Aug 26, 2008 3:44 am 
Offline
Peasant Status
User avatar

Joined: Mon Aug 25, 2008 6:22 am
Posts: 13
I am having an issue with the action submenu (ie, walk/run/sneak/rest/stat/time). I can click on it, and it comes up, but if I move my mouse or click at all .... it blinks off.

This has basically made it so I cannot play a thief, and cannot rest without returning to the inn. CTRL-S and T work for stats and time ... but this is really pretty frustrating.

Also, if I play in a full-screen mode, the mouse is INSANE. Like leaps everywhere at the slightest touch.


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Tue Aug 26, 2008 5:42 am 
Offline
Peasant Status
User avatar

Joined: Mon Aug 25, 2008 2:15 am
Posts: 8
What version of Fusion are you using? I'm using the latest beta, and it's working great for me.

As far as the mouse jumping around in fullscreen mode, that's because you probably have the mouse set up for MotionUngrab or something. Quoting from the VMWare site:
Quote:
Customizing the virtual machine's mouse settings for playing games
Most games require some custom mouse settings to work correctly. These settings lock the mouse to the virtual machine when you are running a game. Note: These settings will affect the acceleration setting of the mouse, and disable the ability to automatically move the mouse between the virtual machine and your Mac. The setting in the user's preference file will also prevent the use of the drag-and-drop feature from all virtual machines to the host machine. Remove the settings to revert back to default behavior.

To customize the virtual machine's mouse settings for playing games, use TextEdit to make the following changes while the virtual machine is powered off:

  • In the virtual machine directory, add the following line to the end of the virtual machine's configuration (.vmx) file:
    vmmouse.present = "FALSE"
  • In your home directory, add the following line to the end of the file ~/Library/Preferences/VMware Fusion/preferences:
    pref.motionUngrab = "FALSE"


These configuration settings do not take effect until you shut down the virtual machine, quit VMware Fusion, and then restart VMware Fusion and the virtual machine.
Note: The configuration file setting vmmouse.present = "FALSE" and the preference file setting pref.motionUngrab = "FALSE" are incompatible with Unity view. To use Unity view, change the configuration file settings for vmmouse.present and pref.motionUngrab to "TRUE" or delete the lines from the configuration file.

Also Note: When you edit a virtual machine's configuration (.vmx) file, if you copy and paste text from a browser into the file using TextEdit, VMware Fusion might be unable to open the resulting .vmx file, because some applications (like Firefox) add legacy Mac characters (carriage returns) at the end of each line. This release of VMware Fusion requires Mac OS X characters (line feeds) at the end of each line, and cannot understand legacy Mac characters. To work around this problem, convert the legacy end-of-line characters in the .vmx file to Mac OS X end-of-line characters:

1. Open Terminal from /Applications/Utilities.
2. Type
nano "~/Virtual Machines/vm-dir/vm-name.vmx"
where vm-dir and vm-name are the path and name of your .vmx file, and press Enter.
3. When nano loads, type Control-O, and press Enter. This converts the legacy end-of-line characters to Mac OS X end-of-line characters.
4. Type Control-X to exit.


I used to do this, but it was too much of a pain, so I upgraded to the beta, and things have been working much better for me now.

--clint


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Tue Aug 26, 2008 6:20 am 
Offline
Peasant Status

Joined: Tue Aug 26, 2008 6:12 am
Posts: 1
Heroes_Do_Not_Talk wrote:
I am having an issue with the action submenu (ie, walk/run/sneak/rest/stat/time). I can click on it, and it comes up, but if I move my mouse or click at all .... it blinks off.

This has basically made it so I cannot play a thief, and cannot rest without returning to the inn. CTRL-S and T work for stats and time ... but this is really pretty frustrating.


I am having the exact same issue with the action submenu under Fusion. I'm running the last stable version of Fusion (1.1.3, I think), not the 2.0 beta, so I would be interested to hear if upgrading to 2.0 fixes this.

For what it is worth, I have the same problem with QFG1 VGA running under a native OSX DosBox client, except I can use the arrow keys to cycle through the action submenu once it comes up. If I touch the mouse at all, it blinks off. In QFG2, the arrow keys don't cycle through the submenu.


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Tue Aug 26, 2008 7:28 am 
Offline
Peasant Status
User avatar

Joined: Mon Aug 25, 2008 6:22 am
Posts: 13
I am using 2.0b .... and still having the issues. I really don't want to have to disable the VMouse every time I want to play the game.

Any other way to fix this? :(


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Wed Aug 27, 2008 1:27 am 
Offline
Peasant Status

Joined: Tue Aug 26, 2008 4:10 am
Posts: 7
Okay. I found a work-around for Parallels. That turning off Vmouse was a work-around gave me the idea.

If you're using Parallels: In Windows, double click on the Parallels icon in your system tray and go to "Mouse Synchronization." Shut mouse synchronization off and everything will be fine.

Then just remember that you can free your mouse from Parallels' grasp using ctrl-option (I think) or cmd-tab'ing to a different app.

At last I can be a thief!


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Wed Aug 27, 2008 2:11 am 
Offline
Peasant Status
User avatar

Joined: Mon Aug 25, 2008 2:15 am
Posts: 8
ARGH!

So apparently I only /thought/ I was using the latest beta. Turns out I was using 2.0a to play it last night. It expired, so today I installed 2.0b.

Now it's broken, and doing the same thing that other users are reporting.

It worked in 2.0a, but now it's broken in 2.0b.

This is indeed a frustrating turn of developments.

My wife is running it under Wine on Ubuntu, but we can't get the right-click to work for her, and there is an annoying lack of keyboard shortcuts to choose the walk/grab/look/talk commands.

--clint

Edit: Okay, fixed the issue. I added this line:
vmmouse.present = "FALSE"

to the middle of this file:
~/Library/Preferences/VMware Fusion/preferences:

And it doesn't seem to have changed any other functionality, but it fixed the menu problem. The game doesn't work in Unity mode, but that's okay -- I don't usually use Unity anyways.


Top
 Profile  
 
 Post subject: Re: Submenu Issue - VMWare Fusion / OS X
PostPosted: Wed Aug 27, 2008 4:45 am 
Offline
Peasant Status
User avatar

Joined: Mon Aug 25, 2008 6:22 am
Posts: 13
Thanks for the fix. I don't run in Unitiy either ... it sucks hard.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group