AGDInteractive - Sierra Adventure Game Remakes Forum
http://www.agdinteractive.com/forum/

Experiencing rather frustrating mouse lag.
http://www.agdinteractive.com/forum/viewtopic.php?f=30&t=15350
Page 1 of 1

Author:  Notlad [ Fri May 13, 2011 2:26 am ]
Post subject:  Experiencing rather frustrating mouse lag.

Tried getting the vga qfg2 running today and I've been experiencing an awkward input lag with the mouse. Whenever I hover the cursor over any frame it can interact with (be it a menu label or game-world person / object) it begins to stutter and act in an unresponsive and choppy manner. In any other space it trails fine, but the behavior persists with any clickable frame / object. Soon as I move it out again, it starts functioning properly again.

I've tried running with all the various combinations of rendering filters for both DirectDraw5 and Direct3D9 to no avail. The only thing that seemed to somewhat alleviate the issue was running in full-screen mode, but the behavior of the mouse was awkward in the manner that it accelerated in a very unintuitive manner. Any mouse gestures based on physical mouse movement were either much slower than I'd expect or much faster and I had trouble controlling it. I tried spending some time in full-screen mode hoping I'd acclimate to the awkward acceleration, but I found it unplayable.

Is there any simple solution to this issue that evades me? Any help would be greatly appreciated for getting the cursor to behave in a windowed mode.

Running what I believe is the most recent version of the game (2.0) that I just downloaded today via AGDI's own page.
Running a fully up-to-date Windows 7, all essential driver updates (video card etc.) from within the last month.

Again, any help would be appreciated as I'd really like to explore this wonderful fan-made update to a timeless classic of a game, but these cursor issues are pushing me towards playing the classic version instead :(.

Author:  DaemonDarqueGS [ Fri May 13, 2011 3:46 am ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

Hmm, I've never experienced that. It ran just fine on my computer, but I played it on Win XP. The only thing I could suggest is perhaps check any firewall or permissions settings that are dragging the game down?

Author:  Notlad [ Fri May 13, 2011 4:19 am ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

DaemonDarqueGS wrote:
Hmm, I've never experienced that. It ran just fine on my computer, but I played it on Win XP. The only thing I could suggest is perhaps check any firewall or permissions settings that are dragging the game down?


Seemed like a longshot, but tried it out anyway.. Same dilemma with firewall off.

I'll try it out via XP virtual machine tomorrow in the absence of an effective solution...
...But please, if anybody has a solution, do tell :P. I'd much rather have it running in a native environment as opposed to having to sideboot into it everytime (granted it's not even going to be an overly long play experience anyway with how many times I've completed the original incarnation.)

It's really puzzling, as it looks like it's a software cursor, but it's just the cursor that lags / stutters around. Any other animations continue unaffected (flickering candle fire on intro screen, Abdulla eating, etc.) So the cursor lag isn't accompanied by any general system lag or framerate loss - it's purely isolated to the cursor when hovering over / near an interactive field / label / object etc.

Author:  DrJones [ Fri May 13, 2011 11:51 am ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

Do this problem affect AGDi's other games? I have seen many reports of troubles and slowdowns with Windows 7 and this game, but not with the other games on the site.

EDIT: Wo-hoo! #1000 posts!

Author:  Notlad [ Fri May 13, 2011 5:32 pm ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

Downloading and installing one of the King's Quest VGA remakes right now to see if it's isolated to just QFG2 or a broader issue with the engine.

Author:  Notlad [ Fri May 13, 2011 7:01 pm ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

Same issue with KQ3, although a touch less pronounced. Still enough to make gameplay a frustrating experience :(

Author:  pulse4J [ Thu May 19, 2011 9:08 am ]
Post subject:  Re: Experiencing rather frustrating mouse lag.

I was having the same issue and am currently running Quest of Glory II in XP (I am running on under VirtualBox.) It seems like the mouse pointer is too fast, right?

This is what worked for me... not ideal, but it works:
1: go into the install directory (default is C:\Program Files\AGD Interactive\Quest for Glory II)
2: right-click Qfg2vga.exe, go to properties
3: go to the compatibility tab
4: check "Run in 640x480 resolution" and hit okay.
5: run the game's launcher.
6: select settings
7: see screenshot if you like, but check "Run in a windows instead of full-screen"
8: set it on DirectDraw 5
9: for graphics filter, select 2x nearest-neighbor filter.
10: click save and run.

Let me know if this helps... it worked for me.

Attachments:
File comment: setup screenshot
screenshot.jpg
screenshot.jpg [ 279.34 KiB | Viewed 1933 times ]

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/