It is currently Sun Feb 18, 2018 7:51 pm

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Walkthrough doesn't match what happens in game?!
PostPosted: Sat May 21, 2011 3:12 am 
Peasant Status

Joined: Sat May 21, 2011 3:03 am
Posts: 1
Here be spoilers

So I just finished playing as a thief, first time I'd played a QFG game in about five years. Long story short, right at the very end (after teleporting from the Forbidden City to the Raseir palace) I started having issues. It was kind of getting on my last nerve because every slight screwup meant I had to sit through that whole unskippable cutscene of a genie blowing up the started to feel ten minutes long every time.

Anyhow, I snuck past the eunuch guarding the front gate, and the genie led me through the palace (as described in text) to a balcony overlooking Khaveen pacing in the corridor below. My first instinct was to throw a dagger at him, but I got the message "all that accomplished was getting his undivided attention" or something to that effect, and boom, the genie sequence which I would soon grow to loathe. Ok so then what? If I waited more than 30 seconds or so, he'd either call the guards on me, or my genie would start screaming and boom, genie cutscene. If I tried shimmying down the rope that was next to me he'd see me, decide it wasn't worth fighting me, and call the guards and boom, genie cutscene. After a few failed attempts I swore to never see the freaking genie cutscene again, and checked a walkthrough (the one on GameFAQ's.)

I discovered that it described a different scenario than what I was actually in. It said that after entering the palace, I should have a "scene" with the harem girls and then continue into a place with a couple eunuchs and then somehow have to use my magic rope as a tightrope to get to Ad Avis. This is absolutely not what was in the game. I assumed next that the remake had switched things up a bit and this was an old walkthrough, but no, it was up to date, and another walkthrough I checked was exactly the same as this.

Anyway, I finally re-tried throwing the dagger, and actually jumped down onto him and offed him ninja-style - turns out that was the right thing to do. But why in God's name does the walkthrough describe such a different sequence than what's actually in the game? And yes, I was without a doubt looking at the thief walkthrough.

 Post subject: Re: Walkthrough doesn't match what happens in game?!
PostPosted: Sat May 21, 2011 3:48 am 
The Prince of Shapeir

Joined: Tue May 08, 2001 4:12 am
Posts: 8872
Location: Phobos
We added this new scenario/solution to the game, because if you're a thief without a Magic Rope, or with too few throwable projectiles remaining (rocks/daggers), then you'll hit a dead-end unwinnable situation after you make it though the harem, and will be unable to finish the game.

The scenario you encountered is by no means the optimal one for thieves, but it gives you a way to finish the game and see the ending where you'd normally be stuck in the original Sierra EGA version. To see the regular harem thief endgame scene, you need to make sure you're carrying a Magic Rope with some charges left and at least 3 or 4 daggers or rocks.

Also, you should be able to skip the Djinni destruction scene with the Esc key.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group